Author Topic: Ej20g GC8 - No fuel, No Spark  (Read 146 times)

0 Members and 2 Guests are viewing this topic.

Offline Reid.Hill

  • Stubbly Faced
  • *
  • Posts: 4
  • Location: Calgary, Alberta
  • Ride: 1995 Subaru Impreza WRX
Ej20g GC8 - No fuel, No Spark
« on: May 27, 2019, 08:26:40 PM »
Hey guys, So I just recently put my car back together after changing the head gaskets and timing on the car and it is not starting up.
I noticed that the fuel pump is not priming, so tested out the fuel pump on 12v and it fires up, bypassed the relay with a wire and fuel pump primes and stays on when key is turned in the ignition.
I have changed the ecu, the crank position sensor, the relays, and checked all the fuses under the hood and in the car and there was no change. I also made sure to see if there were any grounds not hooked up, and there was not.
Upon further testing I am also not getting any spark. I upgraded ej20g coils to the 205 coils because the ones that I had were cracked and not working properly. I followed the post on nasioc, so I looked to see if maybe I messed up some of the wiring.  After looking I did not see any issue with wiring for the conversion – however, I am not fully ruling that out.  If anybody has any coils for an ej20g that they would be willing to lend me to see if that fixes the problem, that would be great too.
I have had a few buddies over to look at the car for me and we are all scratching our heads trying to figure out what the issue is. I am wondering if anyone here has any ideas!
Thanks